Archive

Articles taggués ‘squeeze’

Compte à rebours pour la sortie de Debian Squeeze

25/01/2011 Aucun commentaire

Et oui ce n’est pas un rêve ni un canular, mais Debian 6.0 aka Squeeze est en approche finale.
La release team du projet Debian a annoncé que Squeeze sera dans les bacs le week-end du 5-6 février.
Le 18 janvier Neil McGovern a annoncé sur la mailing list devel de Debian, qu’une Release Candidate de l’installeur avait été publiée.
De nouveaux bugs ont ainsi été découverts et corrigés ce qui a donné lieu à la publication d’une RC2 dans la foulée.

Neil mentionne que cette date ne sera pas appelée à glisser en théorie exceptée si une machine de Build crash ou que la RC2 explose dans une gigantesque boule de feu :-) Voici le lien vers le post de Neil : debian-devel

Dans le même temps la dernière version de Lenny la 5.0.8 est également disponible. Pour ceux qui mettent régulièrement à jour leur distribution, vous êtes à un ou deux paquets près, déjà en 5.0.8. Pour les autres, un sudo aptitude update && sudo aptitude safe-upgrade vous permettra de vous mettre à jour.

Parmi les corrections apportées on trouve :

Corrections de bogues : (liste non exhaustive)

  • spamassasin mise à jour de la liste ARIN pour éviter les faux-positifs RelayEval
  • surfraw mise à jour de l’URL du système de suivi de la sécurité
  • perl problèmes de sécurité liés à l’analyse d’en-tête
  • git-core vulnérabilité de script intersite
  • base-files mise à jour de /etc/debian_version
  • awstats traversée de répertoire à l’aide d’un LoadPlugin compromis
  • mumble empêcher la lecture du fichier de conf par tout le monde

Mises à jour de sécurité : (liste exhaustive)

  • DSA2110 et DSA-2126 dans linux-2.6 plusieurs problèmes
  • DSA-2122 dans glibc augmentation de privilèges
  • DSA-2127 dans wireshark déni de service
  • DSA-2128 dans libxml2 accès mémoire non valable
  • DSA-2131 dans exim4 exécution de code arbitraire à distance
  • DSA-2132 dans xulrunner plusieurs vulnérabilités
  • DSA-2133 dans collectd déni de service
  • DSA-2135 dans xpdf plusieurs vulnérabilités
  • DSA-2136 dans tor débordement de tampon
  • DSA-2137 dans libxml2 plusieurs vulnérabilités
  • DSA-2138 dans wordpress injection SQL
  • DSA-2139 dans phpmyadmin plusieurs vulnérabilités
  • DSA-2140 dasn libapache2-mod-fcgid débordement de pile
  • DSA-2141 dasn apache2, nss et openssl  défaut de conception du protocole
  • DSA-2141 dans apache2-mpm-itk reconstruction avec apache2-src 2.2.9-10+lenny9
  • DSA-2141 dans lighttpd problème de compatibilité avec openssl mis à jour
  • DSA-2142 dans dpkg traversée de répertoires
  • DSA-2143 dans mysql-dfsg-5.0 plusieurs vulnérabilités
  • DSA-2144 dans wireshark débordement de tampon
  • DSA-2145 dans libsmi débordement de tampon
  • DSA-2146 dans mydms  traversée de répertoires
  • DSA-2147 dasn pimd  fichiers temporaires non sécurisés
  • DSA-2148 dans tor plusieurs vulnérabilités

Paquets supprimés : (liste exhaustive)

  • pytris
  • python-gendoc
  • clive
  • gmailfs
  • python-libgmail

Changelog

Tags: , , , , , ,

Debian Squeeze 6.0 sortira avec un kernel 100% libre

22/12/2010 Aucun commentaire

Le Projet Debian a annoncé que la nouvelle version de Debian (juste pour rappel l’un des plus anciens OS GNU/Linux), embarquera une toute nouvelle version du Kernel Linux.
Par là comprenez que le noyau qui sera fourni ne comportera plus aucune partie non-libre en son sein.
Ce travail commencé par les équipes de développement à l’occasion de la sortie de Etch va enfin rencontrer une fin heureuse. Et ça n’est pas pour me déplaire, moi qui n’activent pas les dépôts contrib et non-free sur ma Debian.
Debian se met ainsi 100% en conformité avec son Contrat Social qui en fait l’une des distributions si ce n’est la distribution, la plus respectueuse des standards du Logiciel Libre.
Evidemment dans les faits certains périphériques et autres matériels nécessiteront toujours des parties de logiciels non libres. Dans ce but Debian mettra à disposition ces logiciels dans son dépôt non-free.
Je conclue en disant que ce dépôt non-free fait que Debian n’est toujours pas reconnu comme logiciel libre au sens de la Free Software Foundation.

(source: digitizor)

Tags: , , , ,

Installer Debian Squeeze sur Vaio W

11/02/2010 Aucun commentaire

Voici un tutoriel qui devrait vous être utile si comme moi vous souhaitez installer Debian sur votre Sony Vaio mini (W series).
Je pense qu’il pourra s’appliquer également à d’autres versions ou même d’autres modèles possédant peu ou prou le même hardware.
Quand j’ai pris la décision d’installer Debian j’avais une Ubuntu Karmic Koala installée et parfaitement fonctionnelle.
Voici un aperçu du hardware présent dans le Sony :

  • affichage : Intel 945 GME
  • Ethernet : Attansic/Atheros L1C Gigabit
  • Wifi : Atheros AR9285
  • Son : Intel Corporation 82801G (ICH7 Family)

Le listing du hardware pourra aider ceux qui possèdent un Asus par exemple.

Premier constat, Lenny et son noyau 2.6.26 ne supporte pas les cartes réseau, donc passage sur Squeeze. Une fois l’installation faite le second constat est que l’écran interne ne fonctionne pas. Je dis interne car quand on branche un écran extérieur celà fonctionne et Gnome fait son travail. Un bref aperçu des logs de Xorg fait apparaître cette ligne :

Output LVDS1 disconnected

Après de nombreux essais impossible de faire fonctionner l’écran interne. Après quelques recherches je m’aperçois que c’est lié au noyau 2.6.32-trunk de Testing.
Je décide donc d’installer le noyau 2.6.30 présent dans les dépôts. Effectivement avec le 2.6.30 l’écran fonctionne mais je n’ai plus de réseau !! Du moins la carte ethernet est vue comme connectée avec mii-tool mais impossible d’obtenir une IP depuis le DHCP et le fait de forcer une IP statique ne change rien. Le WIFI lui fonctionne.

Cette solution n’étant pas satisfaisante je décide de me rabattre sur le même noyau que celui que j’avais dans ma Ubuntu à savoir un 2.6.31. Problème le 2.6.31 n’est plus disponible dans les dépôts de Testing ni même de SID.
Je l’ai donc téléchargé depuis kernel.org et il m’a fallu le compiler à la sauce Debian:

Compilation du noyau :

On télécharge les sources depuis kernel.org. Puis on ajoute notre utilisateur au groupe src :

mkdir ~/src 
tar xvjf linux-2.6.31.12.tar.bz2 -C ~/src
cd src
ln -s  linux-2.6.31.12 linux
useradd julien src

On se deconnecte puis on se reconnecte pour que l’ajout de l’utilisateur au groupe src soit effectif.
On installe ensuite des paquets nécessaires à la compilation :

sudo apt-get install libncurses5 libncurses5-dev zlib1g-dev kernel-package

On configure ensuite notre noyau :

cd src 
make menuconfig

Laissez tout par défaut et sortez.

On enchaine avec la compilation en elle même :

fakeroot make-kpkg clean
fakeroot make-kpkg --append-to-version=.`date +%y%m%d`

Une fois terminé (et ca prend beaucoup de temps, et en passant je vous déconseille fortement de le faire sur votre netbook !!) copiez les 2 points .deb ainsi créés sur le netbook et on les installe en faisant :

dpkg -i linux-firmware..............all.deb et linux-image-...........i386.deb

On termine par une mise à jour de Grub2 :

sudo update-grub

Redémarrez sur votre nouveau noyau et constatez que tout fonctionne !!

Tags: , , , , , , ,

KFreeBSD inclue dans Squeeze

31/07/2009 Aucun commentaire

Faisant suite à l’annonce de la nouvelle politique de développement basée sur un calendrier connu, l’équipe gérant les releases nous fait part des nouveautés qu’elle souhaite voir dans Debian GNU/Linux 6.0 (a.k.a Squeeze).
Parmi les nouveautés majeures le noyau KFreeBSD sera inclue d’office dans le projet. Ce qui auparavant n’était qu’un projet lié à Debian (comme évoqué dans ce précédent billet) devient finalement une option d’installation du système à part entière.

Parmi les autres nouveautés, on trouve l’adoption de DASH comme shell par défaut ayant pour principal avantage d’accélérer le temps de boot, le support total d’IPV6, une QA (Quality Assurance) grandement améliorée (double compilation des paquets, rejet automatique des paquets ne passant pas les premiers tests de qualité …), le support des gros fichiers, la suppression des librairies obsolètes renforçant ainsi la sécurité .

Quelques autres souhaits dont vous pouvez consulter la liste ici.

Tags: , , , ,

Squeeze sera le successeur de Lenny

02/09/2008 3 commentaires

Abonné à la liste de diffusion Debian-Devel j’ai pris connaissance hier d’un message de Luke Claes, nous apprenant que le successeur de Lenny s’appellera Squeeze en hommage à l’extraterrestre à 3 yeux de Toy Story.
On y apprend également quelques infos supplémentaires sur la sortie imminente de Lenny.

Tags: , , , ,